APS(4) NetBSD Kernel Interfaces Manual APS(4)
aps -- ThinkPad Active Protection System accelerometer
aps0 at isa? port 0x1600
The aps driver provides support for several sensors found in some ThinkPad laptops. The sensors currently exposed via the envsys(4) interface are: Sensor Units Typical Use X_ACCEL Integer X Acceleration Y_ACCEL Integer Y Acceleration X_VAR Integer Weighted X Acceleration? Y_VAR Integer Weighted Y Acceleration? Temp1 uK Unknown Temp2 uK Unknown Keyboard Active Boolean Keyboard activity Mouse Active Boolean Mouse activity Lid Open Boolean Lid state
The aps driver first appeared in OpenBSD 3.8 and then was ported to NetBSD 5.0.
The aps driver was written by Jonathan Gray <email@example.com>.
The aps driver does not yet maintain state and subsequently does not take evasive action when it thinks the hard drive is in danger. The Y axis on X40 and possibly other models seems to be inverted. It is unknown how to distinguish between different versions of the accelerome- ter to compensate for this in the driver at this time. As IBM provides no documentation, it is not known what all the available sensors are used for. NetBSD 5.1 September 11, 2007 NetBSD 5.1
You can also request any man page by name and (optionally) by section: