AMR(4) NetBSD Kernel Interfaces Manual AMR(4)
amr -- AMI MegaRAID PCI-SCSI RAID driver
amr* at pci? dev ? function ? scsibus* at amr?
The amr driver provides support for LSI (formerly American Megatrends) MegaRAID Express, Elite and Enterprise family RAID controllers for SCSI and SATA, including models relabeled and sold by Dell, Hewlett-Packard, and Intel. Supported controllers include: · MegaRAID 320-1 · MegaRAID 320-2 · MegaRAID Series 418 · MegaRAID Enterprise 1200 (Series 428) · MegaRAID Enterprise 1300 (Series 434) · MegaRAID Enterprise 1400 (Series 438) · MegaRAID Enterprise 1500 (Series 467) · MegaRAID Enterprise 1600 (Series 471) · MegaRAID Elite 1500 (Series 467) · MegaRAID Elite 1600 (Series 493) · MegaRAID Express 100 (Series 466WS) · MegaRAID Express 200 (Series 466) · MegaRAID Express 300 (Series 490) · LSI MegaRAID SCSI 320-0X, 320-2X, 320-4X · LSI MegaRAID SCSI 320-1E, 320-2E · LSI MegaRAID SATA 300-6x, 300-8x · Dell PERC · Dell PERC 2/SC · Dell PERC 2/DC · Dell PERC 4/Di · Dell PERC 4/SC · Dell PERC 4e/Si · HP NetRAID-1/Si · HP NetRAID-3/Si · HP Embedded NetRAID · Intel SRCU42X · Intel SRCU42E · Intel SRMOBU42E · Intel SRCS28X
Driver initialisation/shutdown phase amr%d: memory window not available amr%d: I/O window not available The PCI BIOS did not allocate resources necessary for the correct opera- tion of the controller. The driver cannot attach to this controller. amr%d: busmaster bit not set, enabling The PCI BIOS did not enable busmaster DMA, which is required for the cor- rect operation of the controller. The driver has enabled this bit and initialisation will proceed. amr%d: can't allocate register window amr%d: can't allocate interrupt amr%d: can't set up interrupt amr%d: can't allocate parent DMA tag amr%d: can't allocate buffer DMA tag amr%d: can't allocate scatter/gather DMA tag amr%d: can't allocate s/g table amr%d: can't allocate mailbox tag amr%d: can't allocate mailbox memory A resource allocation error occurred while initialising the driver; ini- tialisation has failed and the driver will not attach to this controller. amr%d: can't obtain configuration data from controller amr%d: can't obtain product data from controller The driver was unable to obtain vital configuration data from the con- troller. Initialisation has failed and the driver will not attach to this controller. amr%d: can't establish configuration hook amr%d: can't scan controller for drives The scan for logical drives managed by the controller failed. No drives will be attached. amr%d: device_add_child failed amr%d: bus_generic_attach returned %d Creation of the logical drive instances failed; attachment of one or more logical drives may have been aborted. amr%d: flushing cache... The controller cache is being flushed prior to shutdown or detach. Operational diagnostics amr%d: I/O beyond end of unit (%u,%d > %u) A partitioning error or disk corruption has caused an I/O request beyond the end of the logical drive. This may also occur if FlexRAID Virtual Sizing is enabled and an I/O operation is attempted on a portion of the virtual drive beyond the actual capacity available. amr%d: polled command timeout An initialisation command timed out. The initialisation process may fail as a result. amr%d: bad slot %d completed The controller reported completion of a command that the driver did not issue. This may result in data corruption, and suggests a hardware or firmware problem with the system or controller. amr%d: I/O error - %x An I/O error has occurred.
cd(4), ch(4), intro(4), pci(4), scsi(4), sd(4), st(4), amrctl(8) NetBSD 8.1 July 23, 2006 NetBSD 8.1
You can also request any man page by name and (optionally) by section: