AMDTEMP(4) NetBSD Kernel Interfaces Manual AMDTEMP(4)
amdtemp -- AMD CPU on-die digital thermal sensor
amdtemp* at pci? dev ? function ?
The amdtemp driver provides support for the on-die digital thermal sensor present on AMD K8, AMD Barcelona, AMD Phenoms, and AMD Griffin CPUs. These sensors were officially introduced in AMD K8 Revision F processors, and provide 0.5 degC accuracy. Precision was improved in Revision G chips, which provide two more bits for 0.25 degC steppings. Each core has two temperature sensors, and there are up to two cores per CPU socket. AMD Barcelona, AMD Phenom, and AMD Griffin provide 0.125 degC accuracy and provide one temperature sensor for each CPU socket. The amdtemp driver reports temperatures through the envsys(4) API. Sensor Units Typical Use CPUN sensor0 uK cpuN temperature
envsys(4), envstat(8), powerd(8)
The amdtemp driver first appeared in OpenBSD 4.4 named ``kate''. It was then ported to NetBSD 5.0. The driver has been renamed with support for newer AMD CPUs.
The amdtemp driver was written by Constantine A. Murenin <email@example.com> whilst at the University of Waterloo. It was adapted to NetBSD by Christoph Egger. NetBSD 5.0_RC4 November 19, 2008 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: