ALTQ(4) NetBSD Kernel Interfaces Manual ALTQ(4)
altq -- alternate queuing framework
options ALTQ options ALTQ_BLUE options ALTQ_CBQ options ALTQ_CDNR options ALTQ_FIFOQ options ALTQ_FLOWVALVE options ALTQ_HFSC options ALTQ_LOCALQ options ALTQ_PRIQ options ALTQ_RED options ALTQ_RIO options ALTQ_WFQ
The altq system is a framework which provides several disciplines for queuing outgoing network packets. While traffic shaping is perhaps the most prominent example, altq provides also other measures related to QoS. The framework has been integrated to the pf(4) packet filter since NetBSD 4.0. At the implementation level altq modifies the interface packet queues. Therefore the driver modifications described in altq(9) are required in order to use a certain network card with altq.
pf(4), altq.conf(5), altqd(8), altq(9) Kenjiro Cho, Fitting theory into reality in the ALTQ case, http://www.sonycsl.co.jp/person/kjc/papers/fittingtheory.pdf, March, 2004, Asia BSD conference.
The altq system first appeared in March 1997 and found its home in the KAME project http://www.kame.net: (). It was imported into NetBSD 1.6.
Please note that you must compile pf(4) in the kernel, using the PF module(7) alongside altq built in the kernel will not work. NetBSD 9.0 March 20, 2018 NetBSD 9.0
You can also request any man page by name and (optionally) by section: