AIBOOST(4) NetBSD Kernel Interfaces Manual AIBOOST(4)
aiboost -- ASUS AI Booster hardware monitor
aiboost* at acpi?
The aiboost driver provides support for monitoring the hardware sensors in recent ASUS motherboards. The driver uses ACPI as the backend to fetch sensor values and descriptions and provides its data via the envsys(4) interface. The aiboost driver typically has 7 sensors, depending on the motherboard and chipset: Sensor Units Typical Use CPU uK CPU Temperature MB uK MB Temperature VCC uV DC Core Voltage +3.3V uV DC +3.3 Voltage +5V uV DC +5 Voltage +12V uV DC +12 Voltage CPU RPM CPU Fan
The aiboost driver first appeared in FreeBSD and then it was ported to NetBSD 5.0.
The aiboost driver was written by Takanori Watanabe and Juan Romero Pardines, who adapted the code for NetBSD.
It's possible to modify voltages via the ACPI methods in the DSDT, but for now the driver only reports the sensors' values. CPU Q-Fan is another thing that is typically specified in the ACPI namespace, and in the future we should handle this feature (to enable or disable auto- matic/manual fan mode). NetBSD 5.0_RC4 March 14, 2007 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: