ACCF_HTTP(9) NetBSD Kernel Developer's Manual ACCF_HTTP(9)
accf_http -- buffer incoming connections until a certain complete HTTP requests arrive
options INET pseudo-device accf_http
This is a filter to be placed on a socket that will be using accept() to receive incoming HTTP connections. It prevents the application from receiving the connected descriptor via accept() until either a full HTTP/1.0 or HTTP/1.1 HEAD or GET request has been buffered by the kernel. If something other than a HTTP/1.0 or HTTP/1.1 HEAD or GET request is received the kernel will allow the application to receive the connection descriptor via accept(). The utility of accf_http is that a server will not have to context switch several times before performing the initial parsing of the request. This effectively reduces the amount of required CPU utilization to handle incoming requests by keeping active processes in preforking servers such as Apache low and reducing the size of the file descriptor set that needs to be managed by interfaces such as select(), poll() or kevent() based servers.
If the accf_data accept filter is present in the kernel configuration, this will enable the http accept filter on the socket sok. struct accept_filter_arg afa; bzero(&afa, sizeof(afa)); strcpy(afa.af_name, "httpready"); setsockopt(sok, SOL_SOCKET, SO_ACCEPTFILTER, &afa, sizeof(afa));
The accept filter mechanism and the accf_http filter were introduced in FreeBSD 4.0. They were ported to NetBSD by Coyote Point Systems and appeared in NetBSD 5.0.
This manual page and the filter were written by Alfred Perlstein. NetBSD 5.0_RC4 September 4, 2008 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: