ACCF_DATA(9) NetBSD Kernel Developer's Manual ACCF_DATA(9)
accf_data -- buffer incoming connections until data arrives
options INET pseudo-device accf_data
This is a filter to be placed on a socket that will be using accept() to receive incoming connections. It prevents the application from receiving the connected descriptor via accept() until data arrives on the connection.
If the accf_data accept filter is present in the kernel configuration, this will enable the data accept filter on the socket sok. struct accept_filter_arg afa; bzero(&afa, sizeof(afa)); strcpy(afa.af_name, "dataready"); setsockopt(sok, SOL_SOCKET, SO_ACCEPTFILTER, &afa, sizeof(afa));
setsockopt(2), accept_filter(9), accf_http(9)
The accept filter mechanism and the accf_data filter were introduced in FreeBSD 4.0. They were ported to NetBSD by Coyote Point Systems and appeared in NetBSD 5.0.
This manual page and the filter were written by Alfred Perlstein. NetBSD 5.0_RC4 August 10, 2008 NetBSD 5.0_RC4
You can also request any man page by name and (optionally) by section: